You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close

macOS 10.15 Catalina, macOS 11 Big Sur and macOS 12 Monterey - Compatibility with Expressive E Products

All our products are working with macOS 10.15 Catalina and macOS 11/12. Existing users should be able to upgrade their systems without problems.

However, our installers for Arché and Noisy are not notarized for macOS 10.15 and higher for the time being.

When installing Arché or Noisy on a computer running macOS 10.15 or higher, you will be shown a message saying

"XXX can’t be opened because Apple cannot check it for malicious software."

To skip this message, control-click or right-click on the *.pkg file and choose "Open" from the context menu. You will get shown a similar message, but this time you will have the possibility to ignore the warning by clicking on the "Open" button.

  • 145
  • 29-Dec-2021
  • 3623 Views